Reporting for Deposits and Returns for Paya is Delayed
Incident Report for STEPpay
Resolved
This issue has been resolved.
Posted Jun 12, 2020 - 13:04 CDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 12, 2020 - 09:52 CDT
Identified
Reporting is delayed for Paya ACH deposits and returns due to Paya's FTP certificate being expired. We are working with Paya on a time frame for them to resolve this issue so that we can report information to our merchants utilizing Paya.

We will continue to update you as we receive more information from Paya. If you have any further questions, please reach out to your Paya representative directly or to your merchant services provider.
Posted Jun 12, 2020 - 09:51 CDT
This incident affected: 3rd Party Services (Payment Processor Integrations) and Reporting & Analytics (STEPpay℠ Reporting Services).