AWS Outage
Incident Report for STEPpay
Resolved
This incident has been resolved.
Posted Dec 08, 2021 - 09:06 CST
Monitoring
The AWS status page is back up so we are able to share excerpts from their latest updates:

[2:43 PM PST] We have mitigated the underlying issue and are seeing improvement in availability across most AWS services. We continue to work toward full recovery for all impacted AWS Services and API operations.

[3:03 PM PST] Many services have already recovered, however we are working towards full recovery across services.

As of this time, STEPpay is not directly experiencing issues, but some of the Processors in which we have integrations may still be having degraded performance which may impact our services.

We will provide updates as we receive them.
Posted Dec 07, 2021 - 17:44 CST
Investigating
AWS (Amazon Web Services), our hosting provider, is experiencing a partial outage that is impacting much of the world. AWS has been unable to update their own status page with details, so we in turn cannot provide an expected resolution time. For perspective, this provides an example of the scale of this issue: https://www.cnbc.com/2021/12/07/amazon-web-services-outage-causes-issues-at-disney-netflix-coinbase.html.

Due to this outage, we are currently having infrastructure issues which may impact some system functionality. As soon as we know more, we will provide an update.
Posted Dec 07, 2021 - 13:28 CST
This incident affected: 3rd Party Services (Payment Processor Integrations, 3rd-Party Software Integrations), Reporting & Analytics (STEPpay℠ Reporting Services, STEPpay℠ Business Analytics Platform, Coalesce Payments℠ Artifact Repository Portal, STEPpay℠ Onboarding Portal), Notification Services (Push Notifications, Email Services), STEPpay℠ Merchant Terminal (Merchant Portal, Scheduled Payments, FTP Server), Application and Database Servers (Sandbox Environment, Application Servers, Database Servers, Vault, Backend Microservices), and API Endpoints (STEPpay℠ JSON API, Legacy SOAP API).