FirstData/Payeezy Service Disruption
Incident Report for STEPpay
Postmortem

From First Data Support:

There was a known issue that prevented processing during the timeframe provided. INC000002658493 was opened to investigate and was reported as resolved around 6:15 PM EDT.

Posted Sep 04, 2020 - 16:34 CDT

Resolved
Last error occurred at 2:54PM and appears to have been resolved.
Posted Sep 02, 2020 - 17:50 CDT
Monitoring
Payeezy errors appear to have been resolved. We are monitoring to see if any issues remain.
Posted Sep 02, 2020 - 14:15 CDT
Update
We have reached out to Payeezy support to try to determine what is going on with the failed requests. We will update the status as more information becomes available.
Posted Sep 02, 2020 - 13:12 CDT
Investigating
We are investigating increased errors being returned from the FirstData/Payeezy processor starting at 9:06AM Central.
Some transactions are going through successfully but many are failing.

We will update this incident as we learn more of this issue.
Posted Sep 02, 2020 - 09:51 CDT
This incident affected: 3rd Party Services (Payment Processor Integrations).